• Login:

Welcome to the Acer Tablet forum.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed.

Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 59
Like Tree8Likes

Thread: Connecting via USB to Linux (Ubuntu)

  1. #11
    Iconia Lurker
    Member #
    575
    Join Date
    Jun 2011
    Location
    New Zealand
    Posts
    7
    Liked
    0 times
    Thank you for this. The thought of having to use Whinedoos to access my OSS Acer tablet was not a pleasant thought. It worked fine on Fedora 14 only exceptions are that you need to download the source for mtpfs and build it yourself and there is no fuse group to join. Now have access to my device via Nautilus. I'm one happy puppy.

    Damm, doesn't work with Fedora 15, /Media is mounted as tmpfs and the folder does not survive a boot.
    Last edited by barfone; 06-16-2011 at 08:17 PM.

  2. #12
    Iconia Informant
    Member #
    97
    Join Date
    May 2011
    Location
    Dallas, Texas
    Posts
    76
    Liked
    11 times
    You're welcome! Glad to help.
    --- When all else fails, there's Linux.

  3. #13
    Iconia Lurker
    Member #
    505
    Join Date
    Jun 2011
    Location
    San Juan, Argentina
    Posts
    15
    Liked
    0 times
    thanks for this!

    worked like a charm in Linux Mint 11 ! I've only had to make a sligth change here:

    9. Add the mount point to fstab.

    Code:

    sudo nano /etc/fstab

    At the bottom of the file, type this stuff:

    Code:

    # mount point for moto xoom
    mtpfs /media/a500 fuse user,noauto,allow_other 0 0

  4. #14
    Iconia Lurker
    Member #
    730
    Join Date
    Jun 2011
    Posts
    2
    Liked
    0 times

    Mistake in the instructions.

    Thank you for the detailed instructions, but you did not change in what is referred to the fstab file.
    I guess that the correct instructions in that point should be as follows:
    # mount point for acer a500
    mtpfs /media/a500 fuse user,noauto,allow_other 0 0

  5. #15
    Iconia Lurker
    Member #
    736
    Join Date
    Jun 2011
    Posts
    1
    Liked
    0 times
    HI and thanks, it was all clear, followed step by step, checked twice, but still... Mine answers ; fuse bad mount point 'media/xoom/' : No such file or directory...

    Does anybody have a clue?

    Thanks anyway

    Dzenieck

  6. #16
    Iconia Lurker
    Member #
    505
    Join Date
    Jun 2011
    Location
    San Juan, Argentina
    Posts
    15
    Liked
    0 times
    Quote Originally Posted by dzenieck View Post
    HI and thanks, it was all clear, followed step by step, checked twice, but still... Mine answers ; fuse bad mount point 'media/xoom/' : No such file or directory...

    Does anybody have a clue?

    Thanks anyway

    Dzenieck
    It is replied right above you! When you

    sudo gedit /etc/fstab

    you gotta write this at the end

    # mount point for acer a500
    mtpfs /media/a500 fuse user,noauto,allow_other 0 0


    PS: be carefull deleting files when you suceed ...

  7. #17
    Iconia Informant
    Member #
    97
    Join Date
    May 2011
    Location
    Dallas, Texas
    Posts
    76
    Liked
    11 times
    I fixed the boo boo in the original post. Thanks for pointing it out.

    /etc/fstab indeed needs to have:

    Code:
    # mountpoint for Acer A500 (this line is a comment)
    mtpfs /media/a500 fuse user,noauto,allow_other 0 0
    dzenieck might need to check fstab for a beginning / in front of /media/a500 . . . /media/a500 is not equal to media/a500. Of course, that may not be it at all.

    g
    Last edited by greg; 06-13-2011 at 05:57 PM.
    --- When all else fails, there's Linux.

  8. #18
    Iconia Lurker
    Member #
    771
    Join Date
    Jun 2011
    Location
    Brighton, UK
    Posts
    7
    Liked
    0 times
    Most excellent! Thank you!

  9. #19
    Iconia Lurker
    Member #
    838
    Join Date
    Jun 2011
    Posts
    1
    Liked
    0 times
    Hello

    I have tried this guide above and still can not connect to my A500 via mini usb (or micro)

    I am running the latest kubuntu, 11.0.4 iirc.

    lsusb output

    Bus 005 Device 002: ID 046d:c06c Logitech, Inc.
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 004: ID 04f2:b044 Chicony Electronics Co., Ltd Acer CrystalEye Webcam
    Bus 002 Device 003: ID 0502:3325 Acer, Inc.
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    /etc/udev/rules.d/51-android.rules
    SUBSYSTEM=="usb", ATTR{idVendor}=="18d1", MODE="0666"
    SUBSYSTEM=="usb", ATTR{idVendor}=="22b8", MODE="0666"
    SUBSYSTEM=="usb", ATTR{idVendor}=="0502", MODE="0666"

    /etc/fstab

    /etc/fstab: static file system information.
    #
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc nodev,noexec,nosuid 0 0
    /dev/sda7 / ext4 errors=remount-ro 0 1
    /dev/sda6 /home ext4 defaults 0 2
    # swap was on /dev/sda5 during installation
    UUID=39845944-5b3e-441b-aa9a-83600cf2a3b3 none swap sw 0 0
    # mount point for acer a500
    mtpfs /media/a500 fuse user,noauto,allow_other 0 0

    mount point created

    /media/a500 and permissions changed to a + x
    drwxr-xr-x 2 user user 4096 2011-06-16 00:19 a500

    mtpfs installed, fuse installed and /etc/group

    fuse:x:104:username

    Any thoughts on what I could check, or what I may be missing to connect to this device? I am very new to android, and not very familure with usb and mtpfs.

    Thanks


    EDIT I should add I have set the usb debugging option on the tablet

    EDIT2 sudo mount /media/a500
    no out put is given
    cd /media/a500
    bash: cd: /media/a500: Transport endpoint is not connected

    EDIT 3 Ok, I turned off the option for USB debugging on the a500 and it now will connect to the pc. However, it seems the a500 automaticly turns on the usb debugging feature some seconds after it is connected. I am then unable to read the files on the device.

    Any suggestions?

    How does one connect these end points?
    Last edited by Dmossman; 06-19-2011 at 08:15 AM.

  10. #20
    Iconia Lurker
    Member #
    858
    Join Date
    Jun 2011
    Posts
    11
    Liked
    0 times
    I have 2 puzzles before me.. Before I go into that however thanks.. got it first run!

    Puzzle 1: sdcards.. for some reason the iconia labels a microsd as 'external_sd' under /mnt no idea why that came about or what Acer was thinking.
    Puzzle 2: Your method works partially in that it does mount sdcard, but it appears that is internal storage and not the actual card inserted in the card slot.

    What I would like to do is get at the contents of the card itself.


 
Page 2 of 6 FirstFirst 1234 ... LastLast

Remove Ads

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

acer a500 linux

,

acer a500 ubuntu

,
acer iconia a500 linux
,

acer iconia a500 ubuntu

,
acer iconia linux
,

acer iconia tab a500 linux

,

acer iconia tab a500 ubuntu

,

acer iconia ubuntu

,

connect android tablet to ubuntu

,

connect android to ubuntu

,
iconia a500 ubuntu
,
mtpfs transport endpoint is not connected
,
ubuntu acer iconia
,

ubuntu acer iconia a500

,
ubuntu on acer iconia a500
Click on a term to search our site for related topics.

Tags for this Thread